cbrown119

Bridge Commander tech help

Recommended Posts

Hello,

Brand new here and looking for some help trying to figure out why BC has stopped working.

I loaded BC up from a disc a few months ago - everything worked fine. I played for a little bit and stopped, then a few months later (now) I started it again - but there are no sounds (there was sounds earlier).  

I tried everything that I know - updated drivers, re-installed multiple times but nothing works.  When I exit the program - it locks up/freezes. I have to sign out of windows to reset the computer. If I close out of the program by hitting the windows button and closing the window - I still have to use the task manager to end the task.

I tried different compatibility settings with no success.

I have a Nvidia GeForce 760 with latest drivers using windows 10. I tried BC on a Surface Pro 2 and that works fine without any compatibility settings. I don't understand how the more powerful computer cannot run it.  There hasn't been any major changes to the desktop besides regular windows updates and Nvidia drivers.

I tried clean installs, clean boots, different troubleshooting websites but nothing seems to work.

Would anyone out there have any suggestions on what could be the problem?  Like I said - it worked before.

Thanks in advance!

 

I must be blind, but I cannot seem to find the "Reply" button anywhere in this topic....

Anyways....First - Thank you for the warm welcome and suggestions and help!

second - I figured out what the problem is/was.  Unfortunately, I had to reset the PC to figure out that it wasn't windows but some sort of conflict with the NVidia card.  After the reset, It worked perfectly.  Then I updated to the latest Nvidia driver - and then the problem came back.  On the Surface 2, it uses Intel (I think) graphic card, that's why it worked without problem. So to get around the Nvidia sound, I just hooked up some external speakers and set the default sound to the installed motherboard.  Now, it works and I am able to actually use the Quit Program to exit without it freezing up.

 

Thank you all for the help and suggestions :)

  

 

Edited by cbrown119

Share this post


Link to post
Share on other sites

Maybe a Windows update screwed something up? Wouldn't be the first time. Under normal circumstances I'd say "uninstall all recent Windows updates and see if the game works now" but I'm not sure this even WORKS with Windows 10.

And... welcome to the forum! ;)

Share this post


Link to post
Share on other sites
rta-man   

First of all, do you have the official v1.1 patch?  If not, we have it here:

http://gaming.trekcore.com/bridgecommander/downloads.html

Next, I'll refer you to the BC pros here:

https://ufplanets.com/showthread.php?40646-Bridge-Commander-Setup&s=7b430197943be9fd6f4909d066a9a02d

These guys have been playing BC for a long time.

Share this post


Link to post
Share on other sites